Script DIO-Tools

DeletedUser54612

Guest
Hello, i have a question. Diotools is my only one script and i have a problem to see the wonders. It's a very big problem, and i hope to go to help me. :( Thanks & good game.
I'm in Google Chrome.

 

H1GH

Chiliarch
got the same problem with wonders even at island view even at ranking in both Chrome and Mozilla ... plz do something to fix it
 

Diony.

Guest
You can deactivate the world wonder ranking feature in the DIO-Tools settings if its not working.
 

DeletedUser54612

Guest
I don't want desactivate the world wonder ranking.
I just want it to work. Like before.
Please, help me.
 

Diony.

Guest
You have to understand... I have a full time job and I don't have much time. Fixing bugs costs much of my free time... Analyzing bugs I can't reproduce costs a lot more time... and I don't get paid for my work. Donations are really rarely and I also have costs for my server. I don't play this game anymore, so I don't develop DIO-Tools for me. I do this for fun, but i don't do it, if you are pushing me.
 

Mike62

Strategos
Many thanks for all the hard work you have put in over the years Dio, I know it must take a chunk of your free time and we are certainly lucky that you enjoy doing this as if you didn't the app would certainly have vanished a long time ago.
Once again thanks from myself and I can say many other of the long term players that have seen so many versions of this app.
 

DeusVult

Chiliarch
This feature isn't working for me:

dio 1.JPG

When i send an attack it will show as this:
dio 2.JPG

I have tried:

-Clearing my cache
-Restarting my browser(google chrome)
-Deleting and reinstalling dio tools
-Restarting my computer

Additional info:

Even if i deactivate this feature it still affects the attack window and wont let me use it. Which means i have to turn off dio tools every time i send an attack. And then i dont have the position memory feature which i find useful.


Any ideas how to fix this? I would greatly appreciate it.
 
Last edited:

maxilex

Hipparchus
There seems to be some issue with this script not working in Tegea - does anyone know why? In the same browser, the script is fine in tabs for Helike and Sinope, but no for the new world.

I also have been having some display issues, like the post above...is there an update in the works?
 

pixie1968

Phrourach
There seems to be some issue with this script not working in Tegea - does anyone know why? In the same browser, the script is fine in tabs for Helike and Sinope, but no for the new world.

I also have been having some display issues, like the post above...is there an update in the works?
I am having the same issue - does anyone know of a solution?
 

Phidippidies

Phrourach
Moving this here for Fluv - issue has been solved for en100 and en101

Howdy

Joined this world today and noticed DIO wasn't working
Managed to find a quick little hotfix
You might need to find how to access this stuff if you're using something else than Chrome, I'm lazy, but the code part should be the same which is the important one

First, open Tampermonkey dashboard by clicking the icon and then, surprise surprise, dashboard

Then, click the diotools thingy in the list

And finally, find the highlighted part in the code
In your version it should say {1,2}
Change this to {1,}
Then don't forget to save

Refresh grepolis for the change to take effect
The tools will now work on every world between 10 and 999
No clue why {1,2,3} doesn't work but not my problem as I only play .en and .nl which are long past the tenth world :p

Now works for all worlds thanks to ThasossCZ, cheers for the help

Have fun playing
Fluv
 

AzureDragon-1

Hipparchus
I have experienced the same issue with this script not working in Tegea. I am using Firefox as a browser. Can anyone tell me what to do in order this scrit to become functional on this world and this browser as well.
 

rabk

Phrourach
I have a problem guys Dio is working great in Rhodes, but in world Byblos it's not there can anyone help.
 

Winchup

Phrourach
I have experienced the same issue with this script not working in Tegea. I am using Firefox as a browser. Can anyone tell me what to do in order this scrit to become functional on this world and this browser as well.
I am not sure if you have solved your issue previously, but just worked out how to get this working on Firefox. Also I have only tried this on Carystus and Dio Tools is now working for me.

It is pretty much the same fix as on Chrome except you have to access the script a different way. Click on the little drop down next to Greasemonkey and click manage user scripts,



Click script settings and then click edit user script,



Make sure the line I have highlighted looks how this one on the screenshot looks (the bit which says {1,} will say {1,2} on un-edited versions as the previous post explains for Google Chrome).
 

Asphixiation

Lochagos
So... I was up until recently using Dio Tools, but for some reason it and GRC wont run in firefox... firefox updated and something changed... but.. if anyone can give me an idea how to either revert fire fox back, or how to work around the update.. that would be sweet.. lol thanks
 

dimspace

Phrourach
So... I was up until recently using Dio Tools, but for some reason it and GRC wont run in firefox... firefox updated and something changed... but.. if anyone can give me an idea how to either revert fire fox back, or how to work around the update.. that would be sweet.. lol thanks
firefox doesnt support legacy extensions anymore so unless tampermonkey/violentmonkey is updated for ff57 you are stuck

but tampermonkey should be updated pretty quickly