Fixing DIO tools for en100 (and beyond)

Discussion in 'World Tegea (en100)' started by Fluvisol, Jul 23, 2017.

  1. Fluvisol

    Fluvisol Hipparchus

    Joined:
    Jun 14, 2016
    Howdy

    Joined this world today and noticed DIO wasn't working
    Managed to find a quick little hotfix
    You might need to find how to access this stuff if you're using something else than Chrome, I'm lazy, but the code part should be the same which is the important one

    First, open Tampermonkey dashboard by clicking the icon and then, surprise surprise, dashboard
    [​IMG]

    Then, click the diotools thingy in the list
    [​IMG]

    And finally, find the highlighted part in the code
    In your version it should say {1,2}
    Change this to {1,}
    Then don't forget to save
    [​IMG]

    Refresh grepolis for the change to take effect
    The tools will now work on every world between 10 and 999
    No clue why {1,2,3} doesn't work but not my problem as I only play .en and .nl which are long past the tenth world :p

    Now works for all worlds thanks to ThasossCZ, cheers for the help

    Have fun playing
    Fluv
     
    Last edited: Jul 23, 2017
    colosal, Orphaeon, Kannerak and 4 others like this.
  2. ThasossCZ

    ThasossCZ Chiliarch

    Joined:
    Jun 16, 2013
    Location:
    North of Czech Republic
    What about {1,3} or {1, }?
     
    Fluvisol likes this.
  3. Fluvisol

    Fluvisol Hipparchus

    Joined:
    Jun 14, 2016
    Not currently on a world other than 100 or 101 so can't test, feel free to try it out
     
  4. pixie1968

    pixie1968 Chiliarch

    Joined:
    Sep 1, 2012
    Thank you - great update
     
  5. Fluvisol

    Fluvisol Hipparchus

    Joined:
    Jun 14, 2016
    Updated, thanks mate
    Seems my lazy butt needs to have a look at coding again, I feel like a nub now, though I could swear {1,3} didn't work before :D
     
  6. ThasossCZ

    ThasossCZ Chiliarch

    Joined:
    Jun 16, 2013
    Location:
    North of Czech Republic
    Never mind, I know this feeling. :D
     
  7. figtree2

    figtree2 Staff Member

    Joined:
    Aug 6, 2012
    Gender:
    Male
    Location:
    United States
    You should post in the dio tools thread about the problem.
     
  8. Swagaliciousz

    Swagaliciousz Hipparchus

    Joined:
    May 15, 2016
    This is how I fixed it (the user included part) so multiple fixes possible
    upload_2017-7-24_2-55-52.png
     
  9. maxilex

    maxilex Hipparchus

    Joined:
    Apr 30, 2015
    many thanks for the fix.. I posted the problem in the diotools section, so will refer to this thread there.

    I wish I knew why that works..but in the end - as long as it does..I am happy :)
     
  10. Khan Pathan

    Khan Pathan Hipparchus

    Joined:
    Jun 4, 2014
    Many thanks. This is a wonderful information.
     
  11. optimuch1

    optimuch1 Chiliarch

    Joined:
    Aug 23, 2013
    Gender:
    Male
    Location:
    United Kingdom
  12. colosal

    colosal Phrourach

    Joined:
    Apr 21, 2010
    Wokrs great, I was looking for this solution
     

Top