Script DIO-Tools

Diony.

Guest
New Version (0.194)


Changelog:
  • IRC chat instead of the alliance chat (FlashPlayer required)
    • Private Chats are possible (sound signal on private message or highlighting of your nick)
    • Green smilies inclusive
    • Access form outside of the game possible (Server: luna.iZ-smart.net, Port: 6667, Channel: #GrepolisEN)
    • Chatter count in the menu
Preview:

 
Last edited by a moderator:

Gulio

Phrourach
Get rid of the Add page between this and your DIO-Tools page @ Userscripts. That is not appropriate and I think against the rules. But, even if it's not against the rules, don't do it. It's just wrong.

Looking at the script, I see you're using base64 strings for the sound/images, but you're also using images on another site. The cross-site reference for images is not pretty, and you have no control over the images on those sites. I'd recommend using base64 strings for those.

Example:

'<div class="m_middle"><img class="m_cont" id="m_uni" src="http://666kb.com/i/cjq6cxia4ms8mn95r.png"></div>'+
'<div class="m_div"></div>'+
'<div class="m_middle"><img class="m_cont" id="m_fav" src="http://s14.directupload.net/images/140120/tvfuuhep.png"></div>'+
'<div class="m_right"></div></div>').appendTo('.nui_toolbar .middle');


You also use an image array which contains an array of images, yet only use it in certain spots and hard code other images in other spots.


Again with the Adds:

$('<div class="smiley_box">'+
'<div class="bbcode_box middle_center"><div class="bbcode_box middle_right"></div><div class="bbcode_box middle_left"></div>'+
'<div class="bbcode_box top_left"></div><div class="bbcode_box top_right"></div><div class="bbcode_box top_center"></div>'+
'<div class="bbcode_box bottom_center"></div><div class="bbcode_box bottom_right"></div><div class="bbcode_box bottom_left"></div>'+
'<div align="center" style="width:100%;">'+
'<a class="group" name="standard" href="">'+ LANG[LID].sml.std +'</a>'+
'<a class="group" name="grepolis" href="">'+ LANG[LID].sml.gre +'</a>'+
'<a class="group" name="nature" href="">'+ LANG[LID].sml.nat +'</a>'+
'<a class="group" name="people" href="">'+ LANG[LID].sml.ppl +'</a>'+
'<a class="group" name="other" href="">'+ LANG[LID].sml.oth +'</a>'+
'</div>'+
'<hr class="smiley_hr">'+
'<div class="smiley_box_cont" style="overflow: hidden;"></div>'+
'<hr class="smiley_hr">'+
'<div align="center" style="margin-top:2px;"><a href="http://adf.ly/eDbBl" target="_blank"><span class="smiley_link">WWW.GREENSMILIES.COM</span></a></div>'+
'</div>').appendTo(bbcodeBarId + ' .bb_button_wrapper');



Putting in Adds in tools like this is just wrong in my books.

I'm not sure about the chat replacement.
 
Last edited:

Diony.

Guest
You're right. That's pretty irritating/annoying. That was just a stupid attempt of mine who has not really convinced me. (I've seen in another script thread)
I've removed it now.


Looking at the script, I see you're using base64 strings for the sound/images, but you're also using images on another site. The cross-site reference for images is not pretty, and you have no control over the images on those sites. I'd recommend using base64 strings for those.
If I only use these base64 strings, then the beginning of my script is much too long. ^^

I'm not sure about the chat replacement.
You can deactivate it in the settings...
 
Last edited by a moderator:

Druvi

Strategos
Dio why isn't the old town overview feature working anymore:/

Edit:nvm works fine now
 
Last edited:

Diony.

Guest
hmm... it should actually work. Please look in the settings, if it is enabled. The rest of the script works for you?
 

Druvi

Strategos
yup everything fine now just for a few seconds the city overview one didnt work.But all right now
Thanks
 

Ast96rix

Guest
The site wont open, been stuck for 2 days now, any suggestions?
 

The SpartanLives

Guest
i like the avaliable units, enjoy the bragging rights. however i dont put my cities into groups, anyway you can make it so its done by ocean or tt around a BB code?

good script though dude
 

ND68

Guest
Hi, I'd restarted Mozilla, downloaded greasemonkey, downloaded DIO-TOOLS, it's enabled and active but it doesn't work. No sign of it on the grepo screen. It worked perfect on a previous Mozilla. It's a same version of Mozilla(the last one) I just had to reinstall it bcse of 2 new pages opened every time I made a click...
 

Diony.

Guest
Hi, I'd restarted Mozilla, downloaded greasemonkey, downloaded DIO-TOOLS, it's enabled and active but it doesn't work. No sign of it on the grepo screen. It worked perfect on a previous Mozilla. It's a same version of Mozilla(the last one) I just had to reinstall it bcse of 2 new pages opened every time I made a click...
It's because userscript.org is completely broken yet... it cuts scripts on random parts, so it will not work. Here is the new download link:

https://greasyfork.org/scripts/1277-dio-tools/code/DIO-TOOLS.user.js
 

dimspace

Phrourach
Thers something weird going on, neither Dio or Quack are working for me today.
Working again now
 
Last edited: